zcgw.net
当前位置:首页 >> mAvEn jstl >>

mAvEn jstl

你的配置是这样的吗: jstl jstl 1.2

报这些错就是依赖的jar包找不到。 一般这些开源的组件都是可以在maven central下到的,你检查下你的mirror(在settings文件中)或者repositories(pom文件中)设置的是否正确

http://central.maven.org/maven2/jstl/jstl http://central.maven.org/maven2/javax/faces/jsf-api/ http://central.maven.org/maven2/javax/faces/jsf-impl/ 三个链接下,自己找版本下

在你的Jetty Plugin里增加对jstl依赖试试: org.mortbay.jetty jetty-maven-plugin 7.6.4.v20120524 ...... javax.servlet jstl 1.2 ......

你使用这个试试: jstl jstl 1.2 虽然不直接用jar包,但引于的地址必须是正确的了。 你多一个source的后缀,很有可能是你某个pom在去下载jar包的时候,并没有成功下载,或你的下载类型有问题。

兄弟 给你一个网址 http://search.maven.org/ 这上面全是使用maven 下载的包 里面啥架包都可以给你搞定。

项目执行方面的java没能被发现。功能将是有限的

引入spring-webmvc

java.lang.NoClassDefFoundError: javax/servlet/jsp/jstl/core/LoopTag 意思就是说,javax.servlet.jsp.jstl.core.LoopTag 这个类找不到,有两个原因,一是不存在这个类,二是这个类有重复,也就是存在多个同样的LoopTag类。你拷jar包后能正确...

[jar:jndi:/localhost/app/WEB-INF/lib/standard-1.1.2.jar! 原因是这个jar包由于位置原因被破坏了,重新拷贝一个新jar包就ok

网站首页 | 网站地图
All rights reserved Powered by www.zcgw.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com